4455 Governors Point

Colorado Springs, CO 80906

4455 Governors Point

Colorado Springs, CO 80906

4455 Governors Point

Colorado Springs, CO 80906

3 Beds 4 Baths 3410 Sq Ft Offered at $635,000 Built in 1998

Wonderful 3 Bedroom Townhome in the Gated Broadmoor Resort Community! This 3 bedroom, 4 bath townhome offers the opportunity for main level living, 2-car garage along with city and mountain views. The main level includes hardwood floors, high ceilings, spacious living and dining room with built-ins, fireplace and walkout to enclosed deck. The terrific kitchen features tile countertops, two dishwashers, gas range, built-in double ovens, breakfast nook, planning desk and island. The master suite, also located on the main level, includes a private 5-piece bath, two walk-in closets and walk-out. There are two additional bedrooms on the lower level including a second master with private bath and walk-in closet. The family room includes a wet bar, walkout to enclosed deck, fireplace and built-ins.

Details

MLS: 3413196


Subdivision: The Villas At Log Hollow

County: El Paso

Bedrooms: 3

Bathrooms:4

Sq Ft: 3410

Price: $635,000

Year Built: 1998

Features

Style: Townhouse (RES, REN)


Roofing: Tile

Siding: Stone,Stucco

Main Level SQFT: 1714

Basement SQFT: 1696 Structure: Wood Frame

Unit Description: Attached

Existing Utilities: Electricity,Natural Gas

Existing Water: Municipal (RES, INC, FRM, REN)

Construction: Existing Home (RES)

Club Amenities:

Agent: Kevin Patterson CRS GRI SFR Brokerage: The Patterson Group

* The real estate listing information and related content displayed on this site is provided exclusively for consumers’ personal, non-commercial use and may not be used for any purpose other than to identify prospective properties consumers may be interested in purchasing. This information and related content is deemed reliable but is not guaranteed accurate by the Pikes Peak REALTOR® Services Corp.

Share this property

Enter an email address and message to share this property.

Valid email is required